const regex = /(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])', 'g')
const str = `
.. 551 .. 552.. 553..
But i need to exclude from that the numbers
55341 55312 55227`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}