#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).*(d|d[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([a@4\p{L}\s]|[a@4\p{L}]e|[a@4\p{L}][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s\p{L}]*)(h|h[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)?[yie€3].*"
Local $sString = "123123213dashie214124124" & @CRLF & _
"" & @CRLF & _
"Dashie" & @CRLF & _
"dashi3" & @CRLF & _
"d.ashie" & @CRLF & _
"da-shie" & @CRLF & _
"das"hie" & @CRLF & _
"dash$ie" & @CRLF & _
"dashi%e" & @CRLF & _
"dashie^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")