$re = '/.*(d|d[~`!@#$%^&:;"\'?|<>*\(\)\[\]\{\}\/\\\\+.,_\-\s]*)([a@4\p{L}\s]|[a@4\p{L}]e|[a@4\p{L}][~`!@#$%^&:;"\'?|<>*\(\)\[\]\{\}\/\\\\+.,_\-\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;"\'?|<>*\(\)\[\]\{\}\/\\\\+.,_\-\s\p{L}]*)(h|h[~`!@#$%^&:;"\'?|<>*\(\)\[\]\{\}\/\\\\+.,_\-\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;"\'?|<>*\(\)\[\]\{\}\/\\\\+.,_\-\s]*)?[yie€3].*/i';
$str = '123123213dashie214124124
Dashie
dashi3
d.ashie
da-shie
das"hie
dash$ie
dashi%e
dashie^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);