const regex = /.*(d|d[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([a@4\p{L}\s]|[a@4\p{L}]e|[a@4\p{L}][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s\p{L}]*)(h|h[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)?[yie€3].*/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(d|d[~`!@#$%^&:;"\'?|<>*\\(\\)\\[\\]\\{\\}\\\/\\\\+.,_\\-\\s]*)([a@4\\p{L}\\s]|[a@4\\p{L}]e|[a@4\\p{L}][~`!@#$%^&:;"\'?|<>*\\(\\)\\[\\]\\{\\}\\\/\\\\+.,_\\-\\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;"\'?|<>*\\(\\)\\[\\]\\{\\}\\\/\\\\+.,_\\-\\s\\p{L}]*)(h|h[~`!@#$%^&:;"\'?|<>*\\(\\)\\[\\]\\{\\}\\\/\\\\+.,_\\-\\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;"\'?|<>*\\(\\)\\[\\]\\{\\}\\\/\\\\+.,_\\-\\s]*)?[yie€3].*', 'ig')
const str = `123123213dashie214124124
Dashie
dashi3
d.ashie
da-shie
das"hie
dash\$ie
dashi%e
dashie^`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}