import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(d|d[~`!@#$%^&:;\"'?|<>*\\(\\)\\[\\]\\{\\}\\/\\\\+.,_\\-\\s]*)([a@4\\p{L}\\s]|[a@4\\p{L}]e|[a@4\\p{L}][~`!@#$%^&:;\"'?|<>*\\(\\)\\[\\]\\{\\}\\/\\\\+.,_\\-\\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;\"'?|<>*\\(\\)\\[\\]\\{\\}\\/\\\\+.,_\\-\\s\\p{L}]*)(h|h[~`!@#$%^&:;\"'?|<>*\\(\\)\\[\\]\\{\\}\\/\\\\+.,_\\-\\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;\"'?|<>*\\(\\)\\[\\]\\{\\}\\/\\\\+.,_\\-\\s]*)?[yie€3].*";
final String string = "123123213dashie214124124\n\n"
+ "Dashie\n"
+ "dashi3\n"
+ "d.ashie\n"
+ "da-shie\n"
+ "das\"hie\n"
+ "dash$ie\n"
+ "dashi%e\n"
+ "dashie^";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}