use strict;
my $str = '123123213dashie214124124
Dashie
dashi3
d.ashie
da-shie
das"hie
dash$ie
dashi%e
dashie^';
my $regex = qr/.*(d|d[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([a@4\p{L}\s]|[a@4\p{L}]e|[a@4\p{L}][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s\p{L}]*)(h|h[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)?[yie€3].*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}