using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(d|d[~`!@#$%^&:;""'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([a@4\p{L}\s]|[a@4\p{L}]e|[a@4\p{L}][~`!@#$%^&:;""'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;""'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s\p{L}]*)(h|h[~`!@#$%^&:;""'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;""'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)?[yie€3].*";
string input = @"123123213dashie214124124
Dashie
dashi3
d.ashie
da-shie
das""hie
dash$ie
dashi%e
dashie^";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}