#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<=\()\d+,\h*|,?\h*\d+\b)(?=[^()]*\))"
Local $sString = "Foo 12 (bar, 13)" & @CRLF & _
"Foo 12 (13, bar, 14, bar)" & @CRLF & _
"Foo (14, 13, 34)" & @CRLF & _
"Foo 12 (bar, 13)" & @CRLF & _
"Foo 12 (13, bar, 14)" & @CRLF & _
"Foo (14, 13)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)