use strict;
my $str = 'Foo 12 (bar, 13)
Foo 12 (13, bar, 14, bar)
Foo (14, 13, 34)
Foo 12 (bar, 13)
Foo 12 (13, bar, 14)
Foo (14, 13)';
my $regex = qr/(?:(?<=\()\d+,\h*|,?\h*\d+\b)(?=[^()]*\))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";