re = /(?:(?<=\()\d+,\h*|,?\h*\d+\b)(?=[^()]*\))/m
str = 'Foo 12 (bar, 13)
Foo 12 (13, bar, 14, bar)
Foo (14, 13, 34)
Foo 12 (bar, 13)
Foo 12 (13, bar, 14)
Foo (14, 13)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result