import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=\\()\\d+,\\h*|,?\\h*\\d+\\b)(?=[^()]*\\))";
final String string = "Foo 12 (bar, 13)\n"
+ "Foo 12 (13, bar, 14, bar)\n"
+ "Foo (14, 13, 34)\n"
+ "Foo 12 (bar, 13)\n"
+ "Foo 12 (13, bar, 14)\n"
+ "Foo (14, 13)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}