using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=\()\d+,\h*|,?\h*\d+\b)(?=[^()]*\))";
string substitution = @"";
string input = @"Foo 12 (bar, 13)
Foo 12 (13, bar, 14, bar)
Foo (14, 13, 34)
Foo 12 (bar, 13)
Foo 12 (13, bar, 14)
Foo (14, 13)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}