# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=\()\d+,\h*|,?\h*\d+\b)(?=[^()]*\))"
test_str = ("Foo 12 (bar, 13)\n"
"Foo 12 (13, bar, 14, bar)\n"
"Foo (14, 13, 34)\n"
"Foo 12 (bar, 13)\n"
"Foo 12 (13, bar, 14)\n"
"Foo (14, 13)")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.