$re = '/(?:(?<=\()\d+,\h*|,?\h*\d+\b)(?=[^()]*\))/m';
$str = 'Foo 12 (bar, 13)
Foo 12 (13, bar, 14, bar)
Foo (14, 13, 34)
Foo 12 (bar, 13)
Foo 12 (13, bar, 14)
Foo (14, 13)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;