#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?(##a.+?#a##b.+?#b|$)"
Local $sString = "#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)