using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(##a.+?#a##b.+?#b|$)";
string substitution = @"$1";
string input = @"#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}