use strict;
my $str = '#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar';
my $regex = qr/.*?(##a.+?#a##b.+?#b|$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";