import Foundation
let pattern = ###".*?(##a.+?#a##b.+?#b|$)"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar"###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)