// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?(##a.+?#a##b.+?#b|$)").unwrap();
let string = "#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}