package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(##a.+?#a##b.+?#b|$)`)
var str = `#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}