$re = '/.*?(##a.+?#a##b.+?#b|$)/m';
$str = '#b|$)foo##abar#a##bfoo#bbar##afoo#a##bbar#bfoobar';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;