# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?x)
( "
(?> (?<=@.) (?>[^"]+|"")*
| (?> [^"\\]+ | \\. )*
)
"
| ' (?> [^'\\]+ | \\. )* '
)
| \/\/ .*
| \/\* (?s) .*? \*\//$1/g;t' <<< "string s = \"sdfsdf\\"\\*sdfsdf*\\\\"\";
string m = @\"as/*d\"\"fg\";
int i /*jjjjj*/ = 0;
char c = '\"'; //\"hjhkjhkj
Console.WriteLine(\"/*df*////***/**//**lol\\\");/**/ //lol"