// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)
( "
(?> (?<=@.) (?>[^"]+|"")*
| (?> [^"\\]+ | \\. )*
)
"
| ' (?> [^'\\]+ | \\. )* '
)
| // .*
| /\* (?s) .*? \*/"#).unwrap();
let string = "string s = \"sdfsdf\\\"\\\\*sdfsdf*\\\\\\\"\";
string m = @\"as/*d\"\"fg\";
int i /*jjjjj*/ = 0;
char c = '\"'; //\"hjhkjhkj
Console.WriteLine(\"/*df*////***/**//**lol\\\\\");/**/ //lol";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}