$re = '~(?x)
( "
(?> (?<=@.) (?>[^"]+|"")*
| (?> [^"\\\\]+ | \\\\. )*
)
"
| \' (?> [^\'\\\\]+ | \\\\. )* \'
)
| // .*
| /\* (?s) .*? \*/~';
$str = 'string s = "sdfsdf\\"\\\\*sdfsdf*\\\\\\"";
string m = @"as/*d""fg";
int i /*jjjjj*/ = 0;
char c = \'"\'; //"hjhkjhkj
Console.WriteLine("/*df*////***/**//**lol\\\\");/**/ //lol';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;