package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)
( "
(?> (?<=@.) (?>[^"]+|"")*
| (?> [^"\\]+ | \\. )*
)
"
| ' (?> [^'\\]+ | \\. )* '
)
| // .*
| /\* (?s) .*? \*/`)
var str = `string s = "sdfsdf\"\\*sdfsdf*\\\"";
string m = @"as/*d""fg";
int i /*jjjjj*/ = 0;
char c = '"'; //"hjhkjhkj
Console.WriteLine("/*df*////***/**//**lol\\");/**/ //lol`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}