import Foundation
let pattern = #"""
(?x)
( "
(?> (?<=@.) (?>[^"]+|"")*
| (?> [^"\\]+ | \\. )*
)
"
| ' (?> [^'\\]+ | \\. )* '
)
| // .*
| /\* (?s) .*? \*/
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
string s = "sdfsdf\"\\*sdfsdf*\\\"";
string m = @"as/*d""fg";
int i /*jjjjj*/ = 0;
char c = '"'; //"hjhkjhkj
Console.WriteLine("/*df*////***/**//**lol\\");/**/ //lol
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)