use strict;
my $str = 'string s = "sdfsdf\\"\\\\*sdfsdf*\\\\\\"";
string m = @"as/*d""fg";
int i /*jjjjj*/ = 0;
char c = \'"\'; //"hjhkjhkj
Console.WriteLine("/*df*////***/**//**lol\\\\");/**/ //lol';
my $regex = qr~(?x)
( "
(?> (?<=@.) (?>[^"]+|"")*
| (?> [^"\\]+ | \\. )*
)
"
| ' (?> [^'\\]+ | \\. )* '
)
| // .*
| /\* (?s) .*? \*/~p;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";