using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
( ""
(?> (?<=@.) (?>[^""]+|"")*
| (?> [^""\\]+ | \\. )*
)
""
| ' (?> [^'\\]+ | \\. )* '
)
| // .*
| /\* (?s) .*? \*/";
string substitution = @"$1";
string input = @"string s = ""sdfsdf\""\\*sdfsdf*\\\"";
string m = @""as/*d""fg"";
int i /*jjjjj*/ = 0;
char c = '""'; //""hjhkjhkj
Console.WriteLine(""/*df*////***/**//**lol\\"");/**/ //lol";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}