# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)//gm;t' <<< "Hello world (see below).
Lorem ipsum(there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Hello world see below.
"