use strict;
my $str = 'Hello world (see below).
Lorem ipsum(there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Hello world see below.
';
my $regex = qr/\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";