import Foundation
let pattern = #"\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello world (see below).
Lorem ipsum(there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Hello world see below.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)