$re = '/\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)/m';
$str = 'Hello world (see below).
Lorem ipsum(there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Hello world see below.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;