#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?"
Local $sString = "user_" & @CRLF & _
"usEr-nAme" & @CRLF & _
"uSer_naMe-Two_" & @CRLF & _
"_Userna-Me_tHree-and-four"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")