re = /(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?/mi
str = 'user_
usEr-nAme
uSer_naMe-Two_
_Userna-Me_tHree-and-four'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end