use strict;
my $str = 'user_
usEr-nAme
uSer_naMe-Two_
_Userna-Me_tHree-and-four';
my $regex = qr/(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}