import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?";
final String string = "user_\n"
+ "usEr-nAme\n"
+ "uSer_naMe-Two_\n"
+ "_Userna-Me_tHree-and-four";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}