const regex = /(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?', 'gmi')
const str = `user_
usEr-nAme
uSer_naMe-Two_
_Userna-Me_tHree-and-four`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}