$re = '/(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?/mi';
$str = 'user_
usEr-nAme
uSer_naMe-Two_
_Userna-Me_tHree-and-four';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);