#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[(data-user="\d+")\h+(data-userId="\d+")\]\s*(.+?)\s*\[\/\](.*)"
Local $sString = "[data-user="12345" data-userId="678910"]" & @CRLF & _
"" & @CRLF & _
" John Smith" & @CRLF & _
"" & @CRLF & _
"[/]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")