import re
regex = re.compile(r"\[(data-user=\"\d+\")\h+(data-userId=\"\d+\")\]\s*(.+?)\s*\[\/\](.*)", flags=re.DOTALL)
test_str = ("[data-user=\"12345\" data-userId=\"678910\"]\n\n"
" John Smith\n\n"
"[/]")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")