re = /\[(data-user="\d+")\h+(data-userId="\d+")\]\s*(.+?)\s*\[\/\](.*)/
str = '[data-user="12345" data-userId="678910"]
John Smith
[/]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end