// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)\[(data-user="\d+")\h+(data-userId="\d+")\]\s*(.+?)\s*\[\/\](.*)"#).unwrap();
let string = "[data-user=\"12345\" data-userId=\"678910\"]
John Smith
[/]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}