using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(data-user=""\d+"")\h+(data-userId=""\d+"")\]\s*(.+?)\s*\[\/\](.*)";
string input = @"[data-user=""12345"" data-userId=""678910""]
John Smith
[/]";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}