package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[(data-user="\d+")\h+(data-userId="\d+")\]\s*(.+?)\s*\[\/\](.*)`)
var str = `[data-user="12345" data-userId="678910"]
John Smith
[/]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}