# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?>\S+[^\S\n]+){3,}?(\S+?)\K\1(?!\S)//gm;t' <<< "00101 blah 0000202 thisisasentencethisisasentence 99929
00102 blah 0000202 thisisasentenc1thisisasentenc1 999292"