import re
regex = re.compile(r"^(?>\S+[^\S\n]+){3,}?(\S+?)\K\1(?!\S)", flags=re.MULTILINE)
test_str = ("00101 blah 0000202 thisisasentencethisisasentence 99929\n"
"00102 blah 0000202 thisisasentenc1thisisasentenc1 999292")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)