re = /^(?>\S+[^\S\n]+){3,}?(\S+?)\K\1(?!\S)/m
str = '00101 blah 0000202 thisisasentencethisisasentence 99929
00102 blah 0000202 thisisasentenc1thisisasentenc1 999292'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result