use strict;
my $str = '00101 blah 0000202 thisisasentencethisisasentence 99929
00102 blah 0000202 thisisasentenc1thisisasentenc1 999292';
my $regex = qr/^(?>\S+[^\S\n]+){3,}?(\S+?)\K\1(?!\S)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";