using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<property[^>]*name=""(username|password)"".*?</property>";
string substitution = @"";
string input = @"<property name=""password"">QWERTY</property><property name=""username"">Hello</property><property name=""passive"">1</property><property name=""password"">Test Password</property><property name=""scheme"">smb</property><property name=""timeout"">10000</property><property name=""username"">RANDOM USER</property><property name=""username"">Sid</property>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}