import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<property[^>]*name=\"(username|password)\".*?</property>";
final String string = "<property name=\"password\">QWERTY</property><property name=\"username\">Hello</property><property name=\"passive\">1</property><property name=\"password\">Test Password</property><property name=\"scheme\">smb</property><property name=\"timeout\">10000</property><property name=\"username\">RANDOM USER</property><property name=\"username\">Sid</property>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}